Perth-WRX.com  

Go Back   Perth-WRX.com > General WRXing > Introductions > Your Driveway
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Like Tree23Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-04-2010, 10:57 PM
wawa's Avatar
Subaru Tech Division
Member
 
Join Date: Aug 2009
Location: Somewhere over the rainbow
Posts: 1,158
Thanks: 13
Thanked 11 Times in 10 Posts
wawa at standard level
Default Evolution of the Bug

Posting this up for Munya (and myself )

December 2007.As she was a month after buying her. Mods at this point included aftermarket rims, stereo system by Alberts and x-force exhaust tip


IWRXOC Dunsborough Supercruise May 08, the car was fairly stock here other than the rims, x-force exhaust and Pedders Coilovers


Colin McRae Memorial Cruise 2009, mods include Link G3 ECU, vf34p20, Zerosports radiator shroud, white line sway bars, anti lift kit, and Hyperflow TMIC.


Showing some bug love on the way to the Collie Evo vs WRX hillclimb, October 2009
__________________
[SIGPIC][/SIGPIC][COLOR="Olive"]www.shantimassage.webs.com[/COLOR]
Masarai Fine Art and Photography www.masaraifineart.webs.com

Last edited by wawa; 11-04-2010 at 03:56 PM.
Reply With Quote
  #2  
Old 10-04-2010, 11:09 PM
wawa's Avatar
Subaru Tech Division
Member
 
Join Date: Aug 2009
Location: Somewhere over the rainbow
Posts: 1,158
Thanks: 13
Thanked 11 Times in 10 Posts
wawa at standard level
Default

By January 2010 new mods include mesh foglight covers, x-force sorst, greddy boast controller, moulded gauge pod, cherry blossom red silicon intake, process west cold air intake, Sti projectors with HID.

Then the problems started. The ECU started throwing codes and is sent to New Zealand to be analysed, the stock ECU goes back in.

Late March 2010 the Sti rims, brembos and braided brake cables arrive.
The rims

The brembos go on










The bug makes an appearance at the Evo vs WRX hillclimb - Jack's Hill ................ in the carpark
__________________
[SIGPIC][/SIGPIC][COLOR="Olive"]www.shantimassage.webs.com[/COLOR]
Masarai Fine Art and Photography www.masaraifineart.webs.com
Reply With Quote
  #3  
Old 11-04-2010, 10:11 AM
RichX's Avatar
Perth WRX Old Skool Cool Dude
Member
 
Join Date: Oct 2006
Location: Pub
Posts: 4,168
Thanks: 30
Thanked 53 Times in 45 Posts
RichX knows their stuff
Default

Nice, similar mod path to mine. What tune is on the car? I have a verso with a 34/P18 and making 190awkw, 340nm. I suspect the P20 will get you over 200awkw but wondering how much laggier it is.

Do you have a full TBE system?
__________________

Should have bought an STI
Reply With Quote
  #4  
Old 11-04-2010, 11:55 AM
Alternate's Avatar
Sir AntiLag
Member
 
Join Date: Jun 2008
Location: Perth - NOR
Posts: 462
Thanks: 6
Thanked 3 Times in 3 Posts
Alternate at standard level
Default

Nice bug

although, 3rd pic from the bottom, theres a bit of an unsightly crack starting to appear that you should probably get bogged up...
Reply With Quote
  #5  
Old 11-04-2010, 02:31 PM
munya's Avatar
Sign me up!
bug love
 
Join Date: Dec 2007
Location: In a donga
Posts: 1,711
Thanks: 64
Thanked 17 Times in 16 Posts
munya at standard level
Send a message via MSN to munya Send a message via Skype™ to munya
Default

Quote:
Originally Posted by RichX View Post
Nice, similar mod path to mine. What tune is on the car? I have a verso with a 34/P18 and making 190awkw, 340nm. I suspect the P20 will get you over 200awkw but wondering how much laggier it is.

Do you have a full TBE system?
got verso tune at the moment with about 190kw at the wheels and not that laggy either my other tune tuned by Rms on the linkG3 has 198kw at the wheels could be more but have pulled the boost down to about 20psi. Got a full tbe and monster hyperflow topmount
__________________
race tape y pipe running .05 bar till spares turn up.

Last edited by munya; 11-04-2010 at 06:15 PM.
Reply With Quote
  #6  
Old 11-04-2010, 06:16 PM
munya's Avatar
Sign me up!
bug love
 
Join Date: Dec 2007
Location: In a donga
Posts: 1,711
Thanks: 64
Thanked 17 Times in 16 Posts
munya at standard level
Send a message via MSN to munya Send a message via Skype™ to munya
Default

Quote:
Originally Posted by Alternate View Post
Nice bug

although, 3rd pic from the bottom, theres a bit of an unsightly crack starting to appear that you should probably get bogged up...
cheers mate work in progress
__________________
race tape y pipe running .05 bar till spares turn up.
Reply With Quote
  #7  
Old 11-04-2010, 07:14 PM
Perth WRX Old Skool Cool Dude
Member
 
Join Date: Jul 2002
Location: Australia
Posts: 6,794
Blog Entries: 6
Thanks: 31
Thanked 49 Times in 35 Posts
BALISTC knows their stuff
Default

Nice one bruv!!!
Reply With Quote
  #8  
Old 11-04-2010, 07:21 PM
munya's Avatar
Sign me up!
bug love
 
Join Date: Dec 2007
Location: In a donga
Posts: 1,711
Thanks: 64
Thanked 17 Times in 16 Posts
munya at standard level
Send a message via MSN to munya Send a message via Skype™ to munya
Default

Quote:
Originally Posted by BALISTC View Post
Nice one bruv!!!
just a little bug love Joe cheers
__________________
race tape y pipe running .05 bar till spares turn up.
Reply With Quote
  #9  
Old 11-04-2010, 07:37 PM
Master D's Avatar
Perth WRX Old Skool Cool Dude
Member
 
Join Date: Jun 2007
Location: Hocking
Posts: 3,514
Blog Entries: 3
Thanks: 199
Thanked 74 Times in 58 Posts
Master D knows their stuff
Default

hey dude. nice chattin to ya today. thats a nice bug you have.
get the other brembos on hahahaha.
__________________
2016 Subaru Outback - Work Wagon
350NM of CVT Goodness
Pit Crew, shit talker.
Reply With Quote
  #10  
Old 11-04-2010, 07:40 PM
munya's Avatar
Sign me up!
bug love
 
Join Date: Dec 2007
Location: In a donga
Posts: 1,711
Thanks: 64
Thanked 17 Times in 16 Posts
munya at standard level
Send a message via MSN to munya Send a message via Skype™ to munya
Default

yeah i will sort out the rear soon mate just got to get the clearance issue sorted first for the rear
__________________
race tape y pipe running .05 bar till spares turn up.
Reply With Quote
Reply

Tags
bug, evolution

« jacobs yellow car | - »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Forester STI - the evolution hybridgx General Subaru Discussion 85 25-09-2008 10:48 PM
wtd:....Evolution 7 norwest_rumbler Wanted 37 21-03-2008 06:59 PM
Evolution forum perthzed General Subaru Discussion 9 06-07-2007 09:12 PM
Evolution blackevo Introductions 15 12-07-2005 11:36 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 08:48 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO