Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > ECU Discussion > MicroTech Discussion
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read


Welcome to Perth-WRX, click here to register!

Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 19-03-2008, 02:48 PM
Kato's Avatar
Burnout!
Member
 
Join Date: Jul 2005
Location: Pimp Corner
Posts: 7,098
Thanks: 7
Thanked 120 Times in 75 Posts
Kato is a guruKato is a guru
Default

I would guess there would be little to no Microtech's in Perth, so it is going to be a hard time finding one.

What exactly is the problem you are having and have you tried an alternative ECU?
__________________
[COLOR="Gray"]550Nm off a 2L... Just wish it was in the dak dak...[/COLOR]
Reply With Quote
  #12  
Old 25-03-2008, 11:54 AM
Potty Training Scoobie Noobie
Member
 
Join Date: Jun 2007
Location: Canning Vale
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Rhys at standard level
Default

The problem I am having is:

The car will run fine (at idle and when reving) but if you slowly rev it up to about 3500 RPM and it will start to stutter, and not rev over that RPM. However If I can cruising in 5th, and drop it back to 3rd (where the revs stay over 4000rpm, it drives perfectly)

The problem exists between 3.5 and 4 grand. Everything to do with the ignition and fuel system is brand new, and the tune has been checked by Rotormotion and is fine.

I havent tried any other ecu's as the Microtech is hard wired in.

If I cant find another lt10's im going to re-pin the plugs to suit the older version LT8, which my friend has to test.
Reply With Quote
  #13  
Old 07-05-2008, 07:09 AM
Potty Training Scoobie Noobie
Member
 
Join Date: Jun 2007
Location: Canning Vale
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Rhys at standard level
Default

Problem sorted, turned out to be Microtech's fault, after I poured buckets of cash into replacing everything else. The most annoying part is that 2x 50cent resistors fixed the problem.......
Reply With Quote
  #14  
Old 07-05-2008, 11:30 AM
mattmy99's Avatar
Sign me up!
Subaru Tech Division
 
Join Date: Mar 2006
Location: 6056 and 4000
Posts: 1,821
Thanks: 11
Thanked 35 Times in 25 Posts
mattmy99 knows their stuff
Default

Good to hear mate. Glad it's all sorted.

Tell us about this build of yours, and why have you opted for Michrotech.

Cheers
Reply With Quote
Reply

Tags
lt10, microtech, owns, plz, read

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO