Perth-WRX.com  

Go Back   Perth-WRX.com > General WRXing > Introductions
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

Sakura Imports
Welcome to Perth-WRX, click here to register!

Like Tree1Likes
  • 1 Post By matto20v

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 26-08-2016, 03:54 PM
Scoobie Noobie
Member
 
Join Date: Jun 2016
Location: SOR
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Ben628 at standard level
Default ECU or Throttle Related

Hi again guys,

Sorry If I'm posting this in the wrong thread, fairly new to the forum and can't seem to navigate well around it yet

Just wanted to ask everyone's opinion.

Yesterday as I was driving through traffic on Canning Highway after work, something rather unusual happened for the first time, basically the car idles at 2100 rpm even at red light and when I had my foot on the brake.

Just suddenly happened and I feel a slight vibration on the clutch, when I engage on the clutch and pedal the rpm drops to normal just after 1000rpm and goes like normal but then when I slow down again approaching traffic it would again for no reason jump to 2100rpm with my foot on brake.

Again throughout this whole experience I feel a slight vibration on the clutch pedal.

Once I get to my destination, switch off the engine and 15 minutes later turn the engine on and drive again, it's normal and hasn't happen again this morning (everything was normal).

Any idea guys what could be the issue? my guess is not having a proper tune?

Quick summary, it's a 99 WRX, mods done is TBE, GD STI TMIC conversion and Manual Boost Controller.

Any ideas and recommendation is much appreciated

Thanks again guys.
Reply With Quote
The Following User Says Thank You to Ben628 For This Useful Post:
STIMUL8IN (29-08-2016)
  #2  
Old 26-08-2016, 05:53 PM
STI Master
Member
 
Join Date: Oct 2010
Location: Spearwood
Posts: 707
Thanks: 8
Thanked 51 Times in 50 Posts
Bram knows their stuff
Default

Neutral switch on gearbox maybe
__________________
Doing it for all the wagons out there
Reply With Quote
  #3  
Old 27-08-2016, 08:41 AM
DCCD Donut Driver
Member
 
Join Date: Apr 2010
Location: perth
Posts: 122
Thanks: 2
Thanked 2 Times in 2 Posts
nwt1976 at standard level
Default

air idle control valve. located on throttle body. remove, clean, and lubricate (wd40) might
help
Reply With Quote
  #4  
Old 27-08-2016, 08:49 AM
matto20v's Avatar
STI Master
Member
 
Join Date: Jul 2005
Location: Perth
Posts: 817
Thanks: 33
Thanked 31 Times in 28 Posts
matto20v at standard level
Default

My guess is Idle Air Control Valve..... sticking, or on the way out.

Google how to clean them on an MY99, in short it's a case of removing it, spraying it with electrical contact cleaner, and re-installing.

It's common for them to be full or carbon and oil and shit after this many years, and they stick or fail.
Reply With Quote
  #5  
Old 29-08-2016, 04:36 PM
Scoobie Noobie
Member
 
Join Date: Jun 2016
Location: SOR
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Ben628 at standard level
Default

Hey guys,

Sorry haven't been able to reply.

Thanks for all that info, I'll get that looked at.

Sorry for the trouble but could you guys point me where I would find this Idle Air Control Valve? possibly with a picture that would be much appreciated.

Thanks again guys
Reply With Quote
  #6  
Old 08-09-2016, 03:53 PM
Scoobie Noobie
Member
 
Join Date: Jun 2016
Location: SOR
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Ben628 at standard level
Default

Hi Guys,

so this idle problem happened again this morning on my way to work and luckily my work is not too far from Subaru Service Centre so I took it down there, did a full diagnostic test and found that the Idle Step Motor is the culprit.

They free up the motor and it's running fine now but they say it may happen again and it may not... who knows....

But they said if it plays up again then I'm up for a new Idle Step Motor and they said it's in the vicinity of $950 ex JAPAN.

They gave me a part no if it makes any sense 22650AA240

Is there anywhere else I can pick up this part from? I don't think it should be that expensive and I've got my local mechanic that I've used and trusted for years to do the job for me if I can source out the part.

Another question would this be the same as Idle Control valve suggested earlier or it's a different part all together? if it is a different part all together, do you guys think it's worth replacing at the same time?

Thanks again guys.
Reply With Quote
  #7  
Old 08-09-2016, 06:18 PM
matto20v's Avatar
STI Master
Member
 
Join Date: Jul 2005
Location: Perth
Posts: 817
Thanks: 33
Thanked 31 Times in 28 Posts
matto20v at standard level
Default

Same thing, yes.

I bought a 3rd party branded unit off Ebay for $70, and it worked perfectly. My thinking was that its worth trying the $70 unit before forking out $900.
nick73 likes this.
Reply With Quote
Reply

Tags
ecu, related, throttle

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock and STI GC8 ECU numbers and specs dtp31 Stock ECU Discussion 7 05-11-2013 06:00 PM
How to Reset your Subaru ECU pmh Stock ECU Discussion 5 06-10-2010 07:18 PM
All new ECU related threads into their specific section. tuna ECU Discussion 0 24-07-2009 06:11 PM
ECU FAQ - What's available pmh ECU Discussion 1 22-07-2007 03:56 PM
antilag REXLLENT Mechanicals 39 06-03-2007 08:45 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 02:14 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO