Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-01-2009, 07:10 PM
Jezza's Avatar
Flat Four Father
Member
 
Join Date: Oct 2008
Location: Swan Valley
Posts: 2,306
Thanks: 20
Thanked 33 Times in 25 Posts
Jezza at standard level
Question process west CAI

hi guys
i have just bought myself one of these from abdus at tenagah, going to install it in the next few days...

(postion once installed)


just wondering if this would get alot of water or excessive dirt from out of the guard... i reckon that this might be a disadvantage of having the air intake not in the engine bay

any thoughts?


cheers,

jeremy
Reply With Quote
  #2  
Old 06-01-2009, 07:27 PM
romeo's Avatar
WRX Hi Five Club
Member
 
Join Date: Apr 2008
Location: western astralia
Posts: 165
Thanks: 0
Thanked 0 Times in 0 Posts
romeo at standard level
Default

abdus did on on my rex sits in the same spot thats what i have been concerned about.
__________________
life begins at 20psi of boost
Reply With Quote
  #3  
Old 06-01-2009, 07:40 PM
GX-REX's Avatar
Sign me up!
The Converter
 
Join Date: Oct 2006
Location: Hocking
Posts: 2,846
Thanks: 13
Thanked 20 Times in 20 Posts
GX-REX at standard level
Default

Yeah they can be a concern if you go through a deep puddle in winter. Suck water into free revving engine = hydrolock = bent rods etc = rebuild engine.

If I had one of these last winter my engine would definately be dead as I went under bayswater subway and didnt know it was flooded.
Reply With Quote
  #4  
Old 06-01-2009, 07:46 PM
romeo's Avatar
WRX Hi Five Club
Member
 
Join Date: Apr 2008
Location: western astralia
Posts: 165
Thanks: 0
Thanked 0 Times in 0 Posts
romeo at standard level
Default

whats the down side to having a normal pod. besides hot air getting sucked in. is there more lag if you are running a bigger turbo.
__________________
life begins at 20psi of boost
Reply With Quote
  #5  
Old 06-01-2009, 07:48 PM
Jezza's Avatar
Flat Four Father
Member
 
Join Date: Oct 2008
Location: Swan Valley
Posts: 2,306
Thanks: 20
Thanked 33 Times in 25 Posts
Jezza at standard level
Default

hmmm not what i wanted to hear! lol

anyone out there with a cai who hasnt had any problems? // or modified the guard setup or something to protect the air intake a lil more?

dont wanna kill the car once it starts raining again :S
Reply With Quote
  #6  
Old 06-01-2009, 07:50 PM
WRXRW
Guest
 
Posts: n/a
Default

i have the pw kit and run it on the 201 without any dramas, come rain, hail or shine!

nice bit of kit, you'll be happy with it!
Reply With Quote
  #7  
Old 06-01-2009, 08:00 PM
type25's Avatar
Subaru Tech Division
Member
 
Join Date: Jun 2008
Location: in exile
Posts: 1,381
Thanks: 12
Thanked 12 Times in 12 Posts
type25 at standard level
Default

I have the APS version which sits in a similar location, have had no issues with it.
Just make sure that you put the guard liner back in.
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #8  
Old 06-01-2009, 08:07 PM
fobz's Avatar
Sign me up!
Subaru Tech Division
 
Join Date: Nov 2005
Location: Perth
Posts: 1,147
Thanks: 9
Thanked 57 Times in 8 Posts
fobz knows their stuff
Default

Just make sure the covers on the inside of the guard are fitted correctly to
keep out the water sprayed up by your wheel going through puddles.
__________________


My flame suit is on. Give it your best biatch.


My STI's carbon emissions are offset by killing puppies.
Reply With Quote
  #9  
Old 06-01-2009, 08:08 PM
Rexy03's Avatar
Sign me up!
BLUE TEAM
 
Join Date: Aug 2007
Location: Australind
Posts: 687
Thanks: 0
Thanked 0 Times in 0 Posts
Rexy03 at standard level
Default

Quote:
Originally Posted by type25
Just make sure that you put the guard liner back in.
Thats the go keep the guard liner installed and as long as you dont go crossing any rivers you will get very little water in there
Reply With Quote
  #10  
Old 06-01-2009, 08:16 PM
vyper's Avatar
Subaru Tech Division
Member
 
Join Date: Jan 2006
Location: SOR
Posts: 1,475
Thanks: 0
Thanked 0 Times in 0 Posts
vyper at standard level
Default

Quote:
Originally Posted by WRXRW
i have the pw kit and run it on the 201 without any dramas, come rain, hail or shine!

nice bit of kit, you'll be happy with it!
x2 - Never had a problem even driving through descent rain/puddles.

As long as the guard's "sealed" up the way it was originally you'll have no problems.
__________________
TD06 - Oink.
Reply With Quote
Reply

Tags
cai, process, west

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 04:26 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO