Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 31-07-2013, 04:47 PM
ALLPAWS's Avatar
STI Master
Member
 
Join Date: Mar 2012
Location: Ivory Tower
Posts: 611
Thanks: 9
Thanked 16 Times in 16 Posts
ALLPAWS at standard level
Default brant system reset

Does anyone know the link to the thread/post to reset the brant system, I flattened my battery and now the car won't start I have had to it b4 but can't find it now. Thanx
__________________
"ALLPAWS" 2014 WRX RS 40 - modding very slowly.
2002 Mitsubishi Airtrek Turbo R - Ralliart Edition (daily)
2010 Nissan GT-R - when the Missus let's me drive it :)
Crotch Rockets . . .
Reply With Quote
  #2  
Old 31-07-2013, 04:53 PM
Intra's Avatar
coming back in 2011
Member
 
Join Date: Jul 2005
Location: Perth
Posts: 1,289
Thanks: 4
Thanked 19 Times in 12 Posts
Intra at standard level
Default

2. Reset Method

Disconnect vehicle battery. Turn ignition switch to on.
When the keypad lights have stopped flashing (this maybe immediately after disconnecting the battery, depending on the state of charge of keypad module battery), wait a further 5 mins before turning off the ignition switch.

After turning off the ignition switch, have someone reconnect the vehicle battery while you hold down the "0" and "#" buttons together. When the vehicle battery has been reconnected, you can release the buttons.
Then hold the "0" button down (it will beep while holding but this is normal)until you see exit countdown delay begin to flash and then release the button.

Allow the system to arm itself then turn on the ignition and enter the user code to disarm the system.
Keypad system is now back to normal.

Method 2 (if your not able to get another person to help you)

If you ever need to reset the brant unit and dont have another person around to help you disconnect the battery lead and press keypad.

Unscrew the six phillips screws holding the glove-box panel and locate the Brant module affixed to the left hand side of the stereo bracket.

Remove the white connector
Press the 0 and # button
Plug in white connector
Reply With Quote
The Following User Says Thank You to Intra For This Useful Post:
ALLPAWS (31-07-2013)
  #3  
Old 31-08-2013, 06:03 AM
Potty Training Scoobie Noobie
Member
 
Join Date: Feb 2012
Location: Mandurah
Posts: 46
Thanks: 0
Thanked 1 Time in 1 Post
Falky at standard level
Default

How did this go for you?
My car shat itself the other day.
I changed battery so assume that had something to do with it(even though that was 2 weeks ago).
Started up, ran for about 10 seconds then cut out and wouldn't play no more.
Didn't have access to here so got RAC to tow it to workshop and let them sort it out.
I've never had an issue in the 3 years I have owneed the car (04 model) but worried that this could become an ongoing issue.
Reply With Quote
  #4  
Old 01-09-2013, 08:34 AM
ALLPAWS's Avatar
STI Master
Member
 
Join Date: Mar 2012
Location: Ivory Tower
Posts: 611
Thanks: 9
Thanked 16 Times in 16 Posts
ALLPAWS at standard level
Default

Yeah the reset method listed below worked for me
but it did happen again(wouldn't start) so I'm thinking it has developed
an intermittent problem ( the best kind )

The RAC guy recommended tearing it all out by an auto electrician or
Subaru specialist as they (brant system) have a habit of screwing up as they get older.
__________________
"ALLPAWS" 2014 WRX RS 40 - modding very slowly.
2002 Mitsubishi Airtrek Turbo R - Ralliart Edition (daily)
2010 Nissan GT-R - when the Missus let's me drive it :)
Crotch Rockets . . .
Reply With Quote
  #5  
Old 01-09-2013, 09:19 AM
thehowlfactor's Avatar
Subaru Tech Division
Member
 
Join Date: May 2013
Location: Perth
Posts: 1,050
Thanks: 13
Thanked 63 Times in 56 Posts
thehowlfactor knows their stuff
Default

Mine seems to have problems too (06 WRX). Not arming even though I have locked the car, not bringing up the lights when trying to disarm. I think a removal is in its future.
Reply With Quote
Reply

Tags
brant, reset, system

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Subaru SA1020 Keypad Security System Instruction Manual (BRANT) DEDLYWEPN Mechanicals 8 31-08-2016 02:45 PM
POS brant system tris7an Mechanicals 25 15-04-2012 12:40 PM
Brant System Failure?! HELP DESPERATE! Syrecx Mechanicals 3 20-03-2012 12:51 AM
BRANT system is always breaking down. mao Mechanicals 2 14-05-2011 09:59 PM
Cost of Brant keypad system or similar JDM_STYLE General Subaru Discussion 20 18-06-2009 08:53 AM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 04:00 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO