Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 30-07-2020, 03:36 PM
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Australia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mrbas11 at standard level
Default Not running after 8S-6S ecu swap

Hey all, I own a 1998 with a full sti engine/gearbox swap from a v3 sti, when I bought the car it was running the 8S ecu and the previous owner gave me the 6S ecu but couldn’t get it running with that ecu, I’ve gone to do the ecu swap and noticed pin 17 on plug b137 was merged with a blue wire, so I disconnected that and put it to pin 7, and have swapped 8 & 10 on b136, plugged in the ecu, it starts but it automatically shuts off after 5 seconds, does anyone know what this issue is & how to fix it? Thanks in advance
Reply With Quote
  #2  
Old 31-07-2020, 02:54 PM
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Australia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mrbas11 at standard level
Default

Anyone? Have installed an Orange stickered afm/maf and now it won’t even start, it started once or twice and when it did it sounds like the engines bogging out and then the automatic shut off kicks in still, was previously running with 8S ecu and F (blue) afm/maf

Last edited by Mrbas11; 31-07-2020 at 02:57 PM.
Reply With Quote
  #3  
Old 31-07-2020, 04:55 PM
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Australia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mrbas11 at standard level
Default

Have plugged the black ‘read memory’ plugs under the dash together to run diagnostics mode and check for any faults shown, I’m just getting continuous same speed flashing/no faults shown..
Reply With Quote
  #4  
Old 31-07-2020, 06:57 PM
Brett Allan's Avatar
Subaru Tech Division
Member
 
Join Date: Jan 2011
Location: NOR scum
Posts: 1,417
Thanks: 48
Thanked 40 Times in 38 Posts
Brett Allan knows their stuff
Default

Not sure with the earlier models, but with the GD's etc if you swap the ECU, you will need the key and transponder from the donor car as they are coded...

Sent from my SM-N976B using Perth-WRX mobile app
__________________
2005 WRX STI
Reply With Quote
  #5  
Old 31-07-2020, 08:14 PM
matto20v's Avatar
STI Master
Member
 
Join Date: Jul 2005
Location: Perth
Posts: 984
Thanks: 37
Thanked 36 Times in 33 Posts
matto20v at standard level
Default

Brett, I think that came in for the 99/00 models, I think...

MrBass11, what do those pin numbers correlate to? Just exactly what is it you have merged or swapped around?
Reply With Quote
  #6  
Old 31-07-2020, 11:45 PM
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Australia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mrbas11 at standard level
Default

Crank and cam sensor pins swapped and the fuel pump pin moved to pin 7 (jdm/without immobiliser position), the same pins that get swapped when installing an apexi ecu

MY97/98 ECU Pin-out & Apexi Fitting - South East Scoobies

And I used this to get into diagnostics mode
http://www.perth-wrx.com/vb/stock-ec...unit-only.html

Last edited by Mrbas11; 31-07-2020 at 11:48 PM.
Reply With Quote
  #7  
Old 01-08-2020, 12:05 AM
Hurtenstein's Avatar
Subaru Tech Division
Member
 
Join Date: Mar 2006
Location: C to tha V
Posts: 1,729
Thanks: 0
Thanked 6 Times in 5 Posts
Hurtenstein at standard level
Default

running for 5 seconds then stalling is an immobilser issue.
__________________
Balls.
Reply With Quote
  #8  
Old 01-08-2020, 02:52 AM
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Australia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mrbas11 at standard level
Default

I was under the impression the JDM version doesn’t have the immobliser function
Reply With Quote
  #9  
Old 01-08-2020, 12:27 PM
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Australia
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mrbas11 at standard level
Default

I just realised my key/car has the immobliser installed, would I need to bypass/remove the immobliser system to allow the car/engine to start with this ecu, and then I wouldn’t be able to reuse the factory immobliser and would have to fit an aftermarket immobliser/alarm/tracker?
Reply With Quote
  #10  
Old 01-08-2020, 01:26 PM
Tony's Avatar
Subaru Tech Division
Member
 
Join Date: Aug 2012
Location: Stoneville
Posts: 1,324
Thanks: 38
Thanked 71 Times in 69 Posts
Tony knows their stuff
Default

Just get an aftermarket ECU
__________________
The one perkent...
Reply With Quote
Reply

Tags
6s, 8s, 8s6s, ecu, running, swap

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Reset your Subaru ECU pmh Stock ECU Discussion 5 06-10-2010 07:18 PM
03,04 & 05 AUS WRX STi Ecu code help waxdass Other ECU Discussion 5 15-07-2008 06:07 PM
ECU swap SilentKilla Other ECU Discussion 13 16-09-2007 12:49 PM
ECU FAQ - What's available pmh ECU Discussion 1 22-07-2007 03:56 PM
44s Link ECU Will swap or sell DAN682 For Sale 0 06-02-2006 08:23 AM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO