Perth-WRX.com  

Go Back   Perth-WRX.com > General WRXing > General Subaru Discussion
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 27-07-2020, 09:24 AM
JYTbSTi's Avatar
Scoobie Noobie
Member
 
Join Date: Jul 2020
Location: Perth
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
JYTbSTi at standard level
Default Indicator hyperflash - not a blown bulb

Hi guys,

A new user here! I am having strange issue with my indicators where they are blinking fast (both left and right). Initially thought it was a blown bulb but now I am a bit unsure.

Hazards are blinking at normal rate and bulbs are all working and doesn’t seem to be burnt out and they are not LED.

Anyone had a similar issue? Could it be the turn signal relay? Or should I just replace all of the indicator bulbs?

I am kinda leaning towards the relay as the hazards work fine but any input would be appreciated. And yes I have replaced the blinker fluids 🤣

Cheers



Sent from my iPhone using Perth-WRX
Reply With Quote
Reply

Tags
blown, bulb, hyperflash, indicator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
subwoofer box and blown woofer kicker Wrx_92 The Quokka 2 18-03-2012 09:37 PM
change sidelight bulb bugeye69 Cosmetic 1 26-06-2010 05:25 PM
wanted light bulb for dash switch gorotsuki69 Wanted 8 01-02-2009 05:32 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 07:47 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO