Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 10-10-2012, 08:35 AM
bryno's Avatar
WRX Hi Five Club
Member
 
Join Date: Aug 2010
Location: Perth
Posts: 154
Thanks: 2
Thanked 4 Times in 4 Posts
bryno at standard level
Default

The fuel pump relay immobilisation circuit can be bypassed, which sounds like it'd fix the issue. If you're any good at soldering you could also try resoldering any broken/dry joints on the brant control module pcb.
Reply With Quote
  #12  
Old 10-10-2012, 08:46 AM
Marti's Avatar
STI Master
Member
 
Join Date: Nov 2007
Location: Beeliar(SOR)
Posts: 745
Thanks: 6
Thanked 21 Times in 21 Posts
Marti at standard level
Default

Fuel pump cut point is under the passenger floor where the ecu sits, easy to bypass and get you driving untill it's fixed Properly
__________________
Marti


Car: C Red S13 Silvia 2.3l 400+rwhp-SOLD
Daily ae82 4age corolla (light mods)-Sold
Daily:SWB GQ Patrol
Will be a 03-04 STI next
Reply With Quote
  #13  
Old 10-10-2012, 09:23 AM
Potty Training Scoobie Noobie
Member
 
Join Date: Feb 2012
Location: Mandurah
Posts: 46
Thanks: 0
Thanked 1 Time in 1 Post
Falky at standard level
Default

I really don't wanna hear all this.
I have a brandt in my 2004 and still works ok..good luck with fixing your problem.
Reply With Quote
  #14  
Old 10-10-2012, 09:53 AM
Marti's Avatar
STI Master
Member
 
Join Date: Nov 2007
Location: Beeliar(SOR)
Posts: 745
Thanks: 6
Thanked 21 Times in 21 Posts
Marti at standard level
Default

All brant systems will shit them selves eventually, if you haven't had problems since 2004 then your doing pretty well
__________________
Marti


Car: C Red S13 Silvia 2.3l 400+rwhp-SOLD
Daily ae82 4age corolla (light mods)-Sold
Daily:SWB GQ Patrol
Will be a 03-04 STI next
Reply With Quote
  #15  
Old 10-10-2012, 09:58 AM
Shodown's Avatar
WRX Hi Five Club
Member
 
Join Date: Jun 2009
Location: Perth
Posts: 181
Thanks: 0
Thanked 0 Times in 0 Posts
Shodown at standard level
Default

Quote:
Originally Posted by silver_opal View Post
Good call. Just know though, its about $500 to get keypad replaced. It does fix the issue. Auto watch very good option.
Quote:
Originally Posted by Marti View Post
City's should have offered to find the issue not just quote a part that "might" fix it, I'd just get it removed or get Mao to have a look
To be honest, it was just a quick call to suss out what it was going to cost roughly. I think it must have been for the module and included labour, but I think I'd just rather replace with a system I wont have to worry about. Could you imagine spending the dollars for it to happen a few years down the track.....

Quote:
Originally Posted by bryno View Post
The fuel pump relay immobilisation circuit can be bypassed, which sounds like it'd fix the issue. If you're any good at soldering you could also try resoldering any broken/dry joints on the brant control module pcb.
Yeah, sounds like either this or the actual fuel pump. Though given Brant's history, I'll start with that.


Quote:
Originally Posted by Falky View Post
I really don't wanna hear all this.
I have a brandt in my 2004 and still works ok..good luck with fixing your problem.
I didn't have any problems until now, and I think its the heat that is affecting it. I am sure there are plenty of people that have not experienced any issues and get pissed off at everyone bagging out Brant. 2004, thats not a bad run considering.

At the end of the day, everything wears out. I'd rather just use the $$ wisely.
__________________
teejay: If I wanted a comeback Id wank in front of a fan
Reply With Quote
Reply

Tags
brant, thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Brant , IACV, MAF, Crank or O2 sensor ???? RoughStilin Mechanicals 25 09-04-2013 10:07 PM
Fuel Pump or Brant?!? Camm Mechanicals 15 30-08-2011 06:37 PM
Brant Master Code......Thread Missing enahs20 Mechanicals 2 17-03-2008 05:02 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 04:08 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO