Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

Tokyo Motorsports
Welcome to Perth-WRX, click here to register!

Like Tree2Likes
  • 1 Post By seagull
  • 1 Post By seagull

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-01-2017, 06:32 AM
Scoobie Noobie
Member
 
Join Date: Dec 2016
Location: SA
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Wilkoridge at standard level
Default Idle issues & Coolant Temp Sensor swap

Morning all

After changing the head gasket, timing belt and water pump I've nearly got the car sorted and driveable... The remaining issue is once the car starts to warm up the idle bounces from 1k - 0 Rpm repeatedly.... I've searched for a leak to no avail and when I unplug the MAF it improves short term only to start lurching again. Spark plugs and leads were changed when everything else was done.. I've been reading and reading and I think the coolant temp sensor may be contributing to this. I changed the temp sensor to a 3 pin and wired in the gauge wire to it in addition to the ecu wires. The temp gauge appears to work and slowly moves up to half way but I cant help thinking that possibly the ecu isn't enjoying the 3 pin approach and not giving the right coolant temp. Anyone got any info on the 3 pins being used on a my98 or earlier? or any other suggestions are much appreciated.
Reply With Quote
  #2  
Old 10-01-2017, 03:39 PM
Subaru Tech Division
Member
 
Join Date: Dec 2005
Location: Kewdale
Posts: 1,700
Thanks: 0
Thanked 51 Times in 34 Posts
seagull knows their stuff
Default

changer the maf sensor
matto20v likes this.
Reply With Quote
  #3  
Old 10-01-2017, 03:40 PM
Subaru Tech Division
Member
 
Join Date: Dec 2005
Location: Kewdale
Posts: 1,700
Thanks: 0
Thanked 51 Times in 34 Posts
seagull knows their stuff
Default

Fit the correct temp sensor
matto20v likes this.
Reply With Quote
Reply

Tags
coolant, idle, issues, sensor, swap, temp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some Engine Coolant facts Rossco Mechanicals 29 21-07-2014 09:51 AM
Report: Scion FR-S, Subaru BRZ rough idle issues require ECU reflash rss.feed General Subaru Discussion 6 09-10-2012 08:47 PM
EJ20K idle issues, looking for advice RedStage Mechanicals 15 09-03-2012 06:49 AM
acceleration and idle issues peppe Mechanicals 47 29-08-2010 08:49 PM
getting coolant temp sensor out tiddy Mechanicals 0 15-02-2010 10:21 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 08:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO