Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read


Welcome to Perth-WRX, click here to register!

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 21-10-2018, 01:08 PM
Potty Training Scoobie Noobie
Member
 
Join Date: Nov 2012
Location: Perth
Posts: 31
Thanks: 1
Thanked 1 Time in 1 Post
SmittyB at standard level
Default Fuel Pump Failure

So I fueled up yesterday and as I went to start to drive away the car started to splutter (like it wasnít getting any fuel).
Rolled it away from the pumps tried a few things but no luck and eventually wouldnít even start. Called road side assistance and he agreed that the pump wasnít working, checked the fuses no issues there. As it was late I got it towed back home.
Next day I disconnect the battery, pulled off the back seat and noticed some fuel coming from the electrical connector coming from the tank, disconnected it and sure enough a few drops of fuel come off it. Took off the cover disconnected the other end of the electrical connector on top of the pump assembly and itís full of fuel. I get some paper towel to soak it up but it fills back up.
I havenít siphoned any fuel out yet as I was just checking and I have to get a small enough hose to do so. However Iím assuming this not normal given petrol and electrical circuits donít mix.
Attached Thumbnails
36CE7FBD-1DE0-4BFE-931D-89B586955610.jpeg  

Last edited by SmittyB; 21-10-2018 at 01:23 PM.
Reply With Quote
  #2  
Old 21-10-2018, 06:12 PM
matto20v's Avatar
STI Master
Member
 
Join Date: Jul 2005
Location: Perth
Posts: 948
Thanks: 38
Thanked 36 Times in 33 Posts
matto20v at standard level
Default

Im going to have a stab in the dark guess.

The seal around the lid of the fuel pump assembly is old, perished, and leaking. When you filled it, it was filled to the max and fuel has leaked or seeped through and now gotten into the connectors. Now you're having a bad time with power getting to the fuel pump.

I'm not a mechanic and its only a guess.
Reply With Quote
  #3  
Old 21-10-2018, 06:21 PM
Potty Training Scoobie Noobie
Member
 
Join Date: Nov 2012
Location: Perth
Posts: 31
Thanks: 1
Thanked 1 Time in 1 Post
SmittyB at standard level
Default

Nah the fuel is coming from what seems to be a hole in where the connector joins the assembly. Found a recall for 09 and prior for a similar issue but not 2010/11.

Also found a foz with same issue https://www.subaruforester.org/vbull...t=595658&amp=1
Reply With Quote
  #4  
Old 21-10-2018, 06:23 PM
Potty Training Scoobie Noobie
Member
 
Join Date: Nov 2012
Location: Perth
Posts: 31
Thanks: 1
Thanked 1 Time in 1 Post
SmittyB at standard level
Default

You can see the black spot around one of the pins in the pic (apologies for quality) I think that’s a hole, and the corresponding connection point is the one that’s burnt out
Reply With Quote
  #5  
Old 25-10-2018, 12:56 AM
Flat Four Father
Member
 
Join Date: Dec 2005
Location: Kewdale
Posts: 2,077
Thanks: 3
Thanked 65 Times in 48 Posts
seagull knows their stuff
Default

Not seen this issue but good to know
Reply With Quote
Reply

Tags
failure, fuel, pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Walbro Fuel pump install Satie12 Mechanicals 5 26-02-2016 10:49 PM
Fuel Pump FAQ Answer's SupaFly Mechanicals 1 14-09-2011 07:45 AM
Fuel pump not Priming. No start. VETTETOREX Mechanicals 19 22-09-2010 02:11 PM
Fuel Pump for Verso Tune gumby General Subaru Discussion 32 25-04-2007 04:01 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO