Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 15-04-2017, 12:06 PM
Scoobie Noobie
Member
 
Join Date: Apr 2017
Location: Caribbean
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
boosted_wrx at standard level
Default Wrx engine phase

Hey folks, I'm from the Caribbean, having some trouble with my 03 edm Wrx did some reading seems to be the same as adm mechanical wise. So here's my question, anyone knows which timing triggers the 03 Wrx carries, my engine was ej205, is this model phase 1 or phase 2, asking cuz I suspect previous owner had a stupid mechanic. Note car was not making boost when working now won't start got misfire in all 4 cylinders, swapped the multi teeth crank sprocket for the one with 6 teeth I believe phase 2 gear and also the matching cam sprocket, not sure if I did the right thing, car still won't start only getting spark on cyc 1 & 3. Need help ty


Sent from my iPhone using Tapatalk
Reply With Quote
  #2  
Old 15-04-2017, 12:08 PM
Scoobie Noobie
Member
 
Join Date: Apr 2017
Location: Caribbean
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
boosted_wrx at standard level
Default

Nb car is non avcs, not same as Jdm Wrx but closer to adm Wrx non avcs early model peanut eye (blob eye)


Sent from my iPhone using Tapatalk
Reply With Quote
  #3  
Old 15-04-2017, 12:18 PM
Scoobie Noobie
Member
 
Join Date: Apr 2017
Location: Caribbean
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
boosted_wrx at standard level
Default


On the right is the one I took off and on the left are the ones I put on


Sent from my iPhone using Tapatalk
Reply With Quote
  #4  
Old 15-04-2017, 05:58 PM
GTLeggy's Avatar
Sir AntiLag
Member
 
Join Date: Mar 2006
Location: Perth
Posts: 409
Thanks: 0
Thanked 21 Times in 12 Posts
GTLeggy at standard level
Default

As far as i can tell from your description, in terms of correct trigger set-up....If it was running(but not making boost).....that's the right trigger set-up ! boost issue is something else un-relate to crank cam signals.(blocked cat, turbo, pump etc)

95% sure off the top of my head an 03 ej205, all be it non avcs had the same spockets as the late avcs stuff....so the fine tooth one.
__________________
MY99 WRX EJ2.35L 720whp 9.48@147mph
https://youtu.be/c_lYEG0_Dyo

Last edited by GTLeggy; 15-04-2017 at 05:59 PM.
Reply With Quote
  #5  
Old 15-04-2017, 07:43 PM
Pimpreza's Avatar
Flat Four Father
Member
 
Join Date: Nov 2006
Location: Slums of Warnbro.
Posts: 2,130
Thanks: 4
Thanked 32 Times in 31 Posts
Pimpreza at standard level
Default

Can't help with the non starting but if the vacuum lines on the turbo have been changed the small brass olive may be missing, squeeze the lines coming or going to the turbo (can't remember which side it is) it's about 3-4mm round with a small hole drilled in the center to restrict air.
__________________
Beaten up old 98 Gen 2 Liberty, 13.0, stock V3 STI running gear.
07 Transit motor home
69 VF & 70 VG Valiants needing full restoration
Yamaha Zooma 50cc rocket hopefully going with the Transit.
Reply With Quote
  #6  
Old 15-04-2017, 10:43 PM
Scoobie Noobie
Member
 
Join Date: Apr 2017
Location: Caribbean
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
boosted_wrx at standard level
Default

Quote:
Originally Posted by GTLeggy View Post
As far as i can tell from your description, in terms of correct trigger set-up....If it was running(but not making boost).....that's the right trigger set-up ! boost issue is something else un-relate to crank cam signals.(blocked cat, turbo, pump etc)

95% sure off the top of my head an 03 ej205, all be it non avcs had the same spockets as the late avcs stuff....so the fine tooth one.


Found the reason why I had no boost, mechanic took my td04 and put in a td035 with out my knowledge, I put in an 18g but I have to put back in my original cam and crank triggers, no cats in the exhaust, pump running and getting fuel pressure


Sent from my iPhone using Tapatalk
Reply With Quote
Reply

Tags
engine, phase, wrx

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The new FA20DIT Performance and Engine Technology motorculture Subaru Australia Forum by MotorCulture 1 11-09-2015 12:20 PM
VIDEO: 2016 Subaru WRX Premium Engine Review motorculture Subaru Australia Forum by MotorCulture 0 10-09-2015 02:32 PM
The new 2016 Subaru WRX is here motorculture Subaru Australia Forum by MotorCulture 4 09-09-2015 12:32 PM
match this chasis number! V5 STi R General Subaru Discussion 19 27-10-2014 01:13 PM
FAQ: Subaru Chasis and Engine Codes pmh Mechanicals 0 10-09-2005 02:34 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 10:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO