Perth-WRX.com  

Go Back   Perth-WRX.com > General WRXing > General Subaru Discussion
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Like Tree9Likes

Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 04-11-2014, 09:40 PM
NEHoward86's Avatar
Scoobie Noobie
Member
 
Join Date: Nov 2014
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
NEHoward86 at standard level
Default

Well my turbo is a lot bigger then stock, so I'd say its been tuned down to 10 cause the engine it self is stock.

All Wheel Grip Not Rear Wheel Slip!!!
Reply With Quote
  #12  
Old 22-11-2014, 04:43 PM
NEHoward86's Avatar
Scoobie Noobie
Member
 
Join Date: Nov 2014
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
NEHoward86 at standard level
Default

Hi, guys

After changing, turbo intake pipe, New air filler, New spark plugs, took intake manifold off and powder coated it. Well after all this I started it up, it idle a little high and backfires when I just touch the peddle a little. Rev it, it seems like it lacks a little bit of response on acceleration. But accelerates great and sounds so sweet. Then and that on idle touch the peddle to see if it will back fire it won't till it idled for a minute then when I touch the peddle it back fires. It's an exhurst back fire that pretty loud and only one at a time.

Just looking to see what I would do next to find a solution. Or cause its getting heaps more air now from the bigger air intake pipe and fillter. And it need to be retuned. ?

Any input would be a great help to where I should start. Thanks guys.

All Wheel Grip Not Rear Wheel Slip!!!
Reply With Quote
  #13  
Old 22-11-2014, 05:49 PM
NEHoward86's Avatar
Scoobie Noobie
Member
 
Join Date: Nov 2014
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
NEHoward86 at standard level
Default

Took this photo while it was on idle from the ems



All Wheel Grip Not Rear Wheel Slip!!!
Reply With Quote
  #14  
Old 23-11-2014, 10:39 AM
NEHoward86's Avatar
Scoobie Noobie
Member
 
Join Date: Nov 2014
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
NEHoward86 at standard level
Default



All Wheel Grip Not Rear Wheel Slip!!!
Reply With Quote
  #15  
Old 23-11-2014, 05:59 PM
Rossco's Avatar
Perth WRX Old Skool Cool Dude
Member
 
Join Date: Apr 2007
Location: Perf, NOR
Posts: 5,515
Blog Entries: 11
Thanks: 54
Thanked 100 Times in 79 Posts
Rossco is a guruRossco is a guru
Send a message via MSN to Rossco
Default

Why does your throttle position switch (TPS) read 99.8%??
At idle it should be 2-5%

Also why are your AFR's at 16:1 at idle? that's extremely lean - no wonder it is backfiring!

I suggest you get this car checked by a reputable tuner before your out $10K for a rebuild!!!

PING Ping BOOM!
__________________
Built Ej207: Semi-closed RA Cases - Wiseco Forgies - Manley rods - BC 272 cams - GDA Heads - billet f/whl - Vi-pec - WbO2 - 800cc Yellow tops - TD05-20G - 409Hp ath @ 1.75bar on E85

Last edited by Rossco; 23-11-2014 at 06:01 PM.
Reply With Quote
  #16  
Old 23-11-2014, 07:44 PM
Pimpreza's Avatar
Flat Four Father
Member
 
Join Date: Nov 2006
Location: Slums of Warnbro.
Posts: 2,130
Thanks: 4
Thanked 32 Times in 31 Posts
Pimpreza at standard level
Default

The VF22 came out on the my96 V2 STI, good turbo and much better than the TD04 you had, it'll handle 18 PSI all day but I'd say you probably need a re-tune by the sound of it.

Have you checked every vacuum hose thoroughly?
__________________
Beaten up old 98 Gen 2 Liberty, 13.0, stock V3 STI running gear.
07 Transit motor home
69 VF & 70 VG Valiants needing full restoration
Yamaha Zooma 50cc rocket hopefully going with the Transit.
Reply With Quote
  #17  
Old 23-11-2014, 08:53 PM
NEHoward86's Avatar
Scoobie Noobie
Member
 
Join Date: Nov 2014
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
NEHoward86 at standard level
Default

It's was afterfiring not backfiring sorry. And I am going to get the car tuned but just going to do all I can first.

Pretty sure iv got a small leak in the IC pipe. Gaped plugs to 0.75, just check the old ones were at 0.85 for some reason. Should I gap them the same as the old ones? I replaced the catch can setup just how it was, but after looking at catch can diagrams today it seems its setup a little different to what the diagrams are telling me. Should I rip the whole catch can system out and replace it how the diagrams are telling me? And one more thing to top it all of the ems stinger is locked and iv tryed heaps of passwords and no dice. Thanks for the input guys anys great and I'm in no hurry to get this done anyways. It's not my daily my 02 rx liberty is. Cheers again guys.

All Wheel Grip Not Rear Wheel Slip!!!
Reply With Quote
  #18  
Old 23-11-2014, 09:06 PM
STI Master
Member
 
Join Date: Jan 2014
Location: WA
Posts: 592
Thanks: 63
Thanked 57 Times in 48 Posts
amtrapid knows their stuff
Default

WTF ..... just WTF..........


Sent from my iPhone using Tapatalk
Reply With Quote
  #19  
Old 23-11-2014, 09:09 PM
NEHoward86's Avatar
Scoobie Noobie
Member
 
Join Date: Nov 2014
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
NEHoward86 at standard level
Default

Whats ya problem mate?

All Wheel Grip Not Rear Wheel Slip!!!
Reply With Quote
  #20  
Old 23-11-2014, 09:15 PM
Tony's Avatar
Subaru Tech Division
Member
 
Join Date: Aug 2012
Location: Stoneville
Posts: 1,301
Thanks: 38
Thanked 68 Times in 66 Posts
Tony knows their stuff
Default

Prob the fact that rossco told you what the problem is, complete with facts, but you basically chose to ignore what he said.
amtrapid likes this.
__________________
The one perkent...
Reply With Quote
Reply

Tags
forums, posting, time

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
First time poster, long time reader... Lil Foley Introductions 30 21-06-2015 12:00 AM
Long time reader, 1st time poster AppleMat Introductions 1 29-09-2014 07:34 AM
New RAC Driving centre event for 2010: Targa Time Attack subarooboy Local Motorsport 23 30-12-2009 08:51 PM
Time to solve all this injector confusion BALISTC General Subaru Discussion 7 07-12-2006 01:47 AM
hello - long time reader, first time poster :) thebish Introductions 5 10-11-2005 03:02 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 09:40 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO