Perth-WRX.com  

Go Back   Perth-WRX.com > Technical > Mechanicals
Register Diddy Kart ArticlesAll AlbumsBlogs FAQ Members List Calendar Search Today's Posts Mark Forums Read

ULTREX
Welcome to Perth-WRX, click here to register!

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 18-08-2011, 02:15 PM
Bigboosst's Avatar
WRX Hi Five Club
Member
 
Join Date: Sep 2010
Location: Perth
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
Bigboosst is unrated
Default Car launch... FAIL

So, decided to try my first launch.. 4.5k Rpm As i released the clutch i was expecting to shoot off, instead, revs skyrocketed and car didn't move. Swapped into second, released clutch, once more the revs raised and car didnt move. Swapped into third, and finally the car moved- Not like it was going to stall either, it just shot off like a rocket.

I couldn't smell any burnt clutch, so a little curious as to why it happened. Clutch feels normal, and the car drives fine- Should i be saving for a new clutch?
  #2  
Old 18-08-2011, 02:19 PM
GTB Liberty's Avatar
Perth WRX Old Skool Cool Dude
Member
 
Join Date: Jun 2009
Location: Mexico - sur del río en capa libre
Posts: 4,037
Thanks: 204
Thanked 140 Times in 92 Posts
GTB Liberty is a guruGTB Liberty is a guru
Default

__________________
Liberty GT Spec B tuned 240 HP & 372 Nm at the hubs. "Instead of banning high performance cars - ban low performance drivers"
  #3  
Old 18-08-2011, 02:19 PM
Rexxar's Avatar
Loud crack pipes?
Member
 
Join Date: Dec 2007
Location: far far SOR
Posts: 2,308
Thanks: 12
Thanked 6 Times in 6 Posts
Rexxar at standard level
Send a message via MSN to Rexxar
Default

so when changing from 1>2>3 the car didnt move at all? did the gears poped out?
__________________
Chinese Mexican
[SIGPIC][/SIGPIC]
  #4  
Old 18-08-2011, 02:20 PM
Perth WRX Old Skool Cool Dude
Member
 
Join Date: Jul 2002
Location: Australia
Posts: 6,794
Blog Entries: 6
Thanks: 31
Thanked 49 Times in 35 Posts
BALISTC knows their stuff
Default

Broken shaft?
  #5  
Old 18-08-2011, 02:28 PM
American Dave's Avatar
The Modulator
Member
 
Join Date: Jun 2006
Location: In your thread
Posts: 8,567
Blog Entries: 2
Thanks: 117
Thanked 104 Times in 90 Posts
American Dave is a guruAmerican Dave is a guru
Default

whs ^^^^
__________________
Funny looking German Subaru
  #6  
Old 18-08-2011, 02:30 PM
Bigboosst's Avatar
WRX Hi Five Club
Member
 
Join Date: Sep 2010
Location: Perth
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
Bigboosst is unrated
Default

I honestly have no idea. It didnt move AT ALL in 1>2 -- Flew off like a bat outta hell in 3rd tho. Drove it home/to work this morning and all gears are working fine- clutch still feels normal =S
  #7  
Old 18-08-2011, 02:32 PM
Mister Two's Avatar
Sleeper Wagon
Member
 
Join Date: Mar 2006
Location: Surface of the Sun
Posts: 4,045
Thanks: 5
Thanked 8 Times in 8 Posts
Mister Two at standard level
Default

Check that one of the driveshafts havent popped out of the splines.
__________________
RS Liberty - Because WRX's are only good for parts...
  #8  
Old 18-08-2011, 02:40 PM
Bigboosst's Avatar
WRX Hi Five Club
Member
 
Join Date: Sep 2010
Location: Perth
Posts: 250
Thanks: 0
Thanked 0 Times in 0 Posts
Bigboosst is unrated
Default

Whats a driveshaft/spline? And where are they located?

=D Would the car still drive normally/Gears work if they driveshaft had popped out?
  #9  
Old 18-08-2011, 02:43 PM
gorotsuki69's Avatar
STI Master
Member
 
Join Date: Jul 2005
Location: Perth
Posts: 910
Thanks: 16
Thanked 9 Times in 8 Posts
gorotsuki69 at standard level
Default

sounds more like a WIN
__________________
There's a hoon in every Typhoon
  #10  
Old 18-08-2011, 02:44 PM
karina2009's Avatar
Subaru Tech Division
Member
 
Join Date: Jun 2010
Location: Freo, WA
Posts: 1,038
Thanks: 6
Thanked 0 Times in 0 Posts
karina2009 is unrated
Default

google works for me
__________________
KB.
Closed Thread

Tags
car, fail, launch

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lucky Number Thirteen jesstamic Your Driveway 122 14-05-2011 09:48 PM
How long do you warm your car up for? BALISTC General Subaru Discussion 99 01-09-2010 01:15 PM
Motor4Toys charity car show attracts Leno and his Turbine rss.feed General Subaru Discussion 0 10-12-2009 07:20 PM
Car Detailing- Waterless wash JTR Cosmetic 3 28-06-2009 09:09 AM
hire car or 1k car??? scoobygez Non-WRX Discussion 37 24-11-2008 11:38 PM



Welcome to Perth-WRX, click here to register!

All times are GMT +8. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO